Chapter 2. Using the pgExpress Driver

1. Requirements

The basic requirements for using the pgExpress Driver are:

  • Delphi 6+, Kylix, or Codegear C++ Builder 6+;, with dbExpress
  • A libpq library compatible with the server version the driver will connect.
  • A compatible PostgreSQL server version 7.1 or newer should work fine, but we recommend using at least version 7.4, or preferably, the latest one.

1.1. Libpq

Please install the 32 bits PostgreSQL distribution in your operating system, and the libpq should be installed along it. Most users will want to install PostgreSQL for Windows; libpq and all its dependencies will be installed along it.

Another option is installing just the libpq.dll and all its dependencies from the binary package provided by the EnterpriseDB site.


  • Prior to version 4.60, the pgExpress package used to include a libpq library. It was meant to be easier to use/test the driver, however it was from an older version which is now deprecated in favor of newer version that have more dependencies.
  • When deploying your application, don't forget to deploy the libpq library file (ex: libpq.dll (Windows) / (Linux)) and all its dependencies (ex: libiconv-2.dll, MSVCR90.DLL etc.); otherwise, you'll likely run into runtime dependency errors.